Service Portal Emails Offline
Incident Report for DoIT
Resolved
This incident has been resolved.
Posted May 19, 2023 - 15:09 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 19, 2023 - 13:25 EDT
Investigating
Email features related to our service portal are offline. We are currently investigating the issue.
Posted May 19, 2023 - 11:04 EDT
This incident affected: IT Service Portal (service.stonybrook.edu).