Amazon Web service disruption is causing a delay

Incident Report for DoIT

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 09:11 EDT

Monitoring

Issues with Amazon Web services are causing latency/delays with log in and system response times. Details can be found on Amazon's status page: https://health.aws.amazon.com/health/status as well as individual companies websites

D2L's status page: https://status.d2l.com/
Echo360: https://status.echo360.com/
Posted Oct 20, 2025 - 10:33 EDT
This incident affected: Student and Faculty Services (Brightspace, Echo360).