Student Payment Issues
Incident Report for DoIT
Resolved
The communications issue between SOLAR and our Payment Processor, TouchNet, has been resolved. The Student Financial Services office continues to monitor for any unexpected behavior.
Posted May 13, 2022 - 11:09 EDT
Investigating
We are aware of an issue with our payment processor, TouchNet, which is causing students to be unable to make payments via SOLAR. Our technical resources have engaged TouchNet and are working on a resolution.
Posted May 13, 2022 - 10:20 EDT
This incident affected: SOLAR.