We are continuing to monitor for any further issues.
Posted Apr 27, 2026 - 12:14 EDT
Update
DoIT is continuing to implement and monitor the fix. The underlying issue has been rectified and the team is currently fixing residual issues, including updating data to downstream systems.
Posted Apr 24, 2026 - 16:07 EDT
Monitoring
DoIT is implementing a fix. We will continue to monitor to ensure all affected users regain their access
Posted Apr 24, 2026 - 11:39 EDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 24, 2026 - 09:58 EDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 24, 2026 - 09:54 EDT
Identified
DoIT has received reports that multiple Google accounts were deactivated. The team has been actively working this morning to restore access and reactivate affected accounts.
Posted Apr 24, 2026 - 09:40 EDT
This incident affected: G Suite (Google Apps) (Google Apps Gmail, Google Apps Drive, Google Apps Calendar, Google Apps Docs, Google Apps Sheets, Google Apps Slides, Google Apps Groups, Google Apps Hangouts, Google Apps Sites).