TeamDynamix - Investigating elevated response times

Incident Report for DoIT

Resolved

This incident has been resolved.
Posted Jul 31, 2026 - 17:11 EDT

Monitoring

Slow/degraded loading of TDWorkManagement interface pages should be resolved as of now. An explanation of the root cause will be provided as soon as it is available, but we have seen performance levels return to normal for all partitions affected.
Posted Jul 30, 2026 - 13:57 EDT

Investigating

TeamDynamix is currently investigating reports of latency. They will provide updates as soon as possible.
Posted Jul 30, 2026 - 12:06 EDT
This incident affected: TeamDynamix IT Service Management Platform.