External emails not being received in Google

Incident Report for DoIT

Resolved

Google’s engineers implemented a fix last night. External emails that were not received during the day were sent after the fix was implemented. If you are still experiencing issues pleas contact our service desk via this link: https://help.stonybrook.edu/TDClient/277/Portal/Requests/ServiceDet?ID=7808 or call 631-632-9800
Posted Apr 09, 2026 - 07:09 EDT

Identified

Update from Google Workspace Status Dashboard (https://www.google.com/appsstatus/dashboard/incidents/224ozRqzW4sFBDK8hLnT)

We are aware of an issue with Gmail users experiencing delays in receiving and sending emails beginning at Wednesday, 2026-04-08 06:30 PDT / 9:30AM EST.

Mitigation work is currently underway by our engineering team. We do not have an ETA for mitigation at this point.

We will provide an update by Wednesday, 2026-04-08 12:00 PDT with current details.

Workaround: None at this time.
Posted Apr 08, 2026 - 14:43 EDT

Update

Google has confirmed it's a system wide issue and their technicians are working to identify.
Posted Apr 08, 2026 - 12:58 EDT

Investigating

Stony Brook's google system is not receiving messages from any external senders. Our team is in contact with Google and this status will be updated when we have more information.
Posted Apr 08, 2026 - 12:50 EDT
This incident affected: G Suite (Google Apps) (Google Apps Gmail).