Potential issue with Google Mail.
Incident Report for DoIT
Resolved
As per Google, "We saw a surge in traffic starting around 7:25 AM Pacific Time on March 5, and we scaled up our systems to serve the additional load."
Posted Mar 05, 2024 - 12:47 EST
Investigating
Reposted from the Google Apps Dashboard. ( no indication thus far that SB users are affected. )

"Some Gmail users are experiencing elevated error rates while performing various actions and may also see delays in email delivery"
Posted Mar 05, 2024 - 11:43 EST
This incident affected: G Suite (Google Apps) (Google Apps Gmail).