Reported Issues using Respondus Monitor
Incident Report for DoIT
Resolved
The vendor has resolved this issue.
Posted Jul 22, 2020 - 19:41 EDT
Investigating
We are currently investigating a report of an invalid number of seats available when using Respondus Monitor with the Vendor's technical support team.
Posted Jul 22, 2020 - 17:03 EDT
This incident affected: Student and Faculty Services (Respondus Lockdown Browser & Respondus Monitor).