IT Service Portal: Cherwell

Incident Report for DoIT

Resolved

This incident has been resolved.
Posted Jun 19, 2020 - 15:56 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 19, 2020 - 14:01 EDT

Investigating

We have received reports that the Cherwell system is experiencing issues. It is slow to respond. The team is contacting the vendor.
Posted Jun 19, 2020 - 12:35 EDT
This incident affected: TeamDynamix IT Service Management Platform.