Google
Incident Report for DoIT
Resolved
Issues with Google Suite had been resolved (as of 13:26 PM 3/26/20, there was a lag in mail delivery yesterday.
Posted Mar 27, 2020 - 07:56 EDT
Investigating
Google is investigating the issue.
Posted Mar 26, 2020 - 20:51 EDT
Monitoring
Google Service (G Suite) has been restored for some users.
Posted Mar 26, 2020 - 19:41 EDT
Investigating
There is an issue with all Google (G Suite) Apps. An updated is expected within an hour.
Posted Mar 26, 2020 - 18:38 EDT
This incident affected: G Suite (Google Apps) (Google Apps Gmail, Google Apps Drive, Google Apps Calendar, Google Apps Docs, Google Apps Sheets, Google Apps Slides, Google Apps Groups, Google Apps Hangouts, Google Apps Sites).