SafeAssign slow to process files
Incident Report for DoIT
Resolved
The vendor reports that this issue has been resolved and SafeAssign documents are processing normally.
Posted Apr 21, 2020 - 11:36 EDT
Investigating
SafeAssign's vendor is reporting that servers are slow to process files being checked against the plagiarism-detection database. The vendor states that processing may take up to several hours for files to process and generate an originality report.
Posted Apr 20, 2020 - 16:57 EDT
This incident affected: Student and Faculty Services (SafeAssign).