SBU My Password Maintenance

Scheduled for Jul 30, 12:00 - 13:00 EDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Jul 20, 2026 - 10:31 EDT

Scheduled

We will be undergoing scheduled maintenance during this time. No password changes can be made during this time. This applies to NetID, SOLAR, and PeopleSoft passwords.
Posted Jul 20, 2026 - 10:30 EDT
This scheduled maintenance affects: Accounts and Passwords (NetID / Single Sign On (SSO)).