PeopleSoft Production Systems.
Incident Report for DoIT
Resolved
All appears to be functioning normally at this time.
Posted Feb 12, 2020 - 15:01 EST
Investigating
There may be a slow response time while accessing both Campus Solutions ( CS ) and Human Capital Management ( HCM ) systems. There is an issue with a database.

System Administrators monitoring.
Posted Feb 12, 2020 - 11:10 EST
This incident affected: PeopleSoft.