Cloudflare.com issue

Incident Report for DoIT

Resolved

Sites can now be accessed.
Posted Nov 18, 2025 - 09:42 EST

Investigating

Trying to access SOLAR, FixIt, and StonyBrook.edu website, users are seeing message, "Internal server error Error code 500". Cloudflare.com is aware of issue and will post updates as they become available.
Posted Nov 18, 2025 - 08:38 EST
This incident affected: SOLAR, Collaboration and Publishing (Stony Brook Website), and Student and Faculty Services (FIXIT).