Blackboard Intermittent Issues
Incident Report for DoIT
Resolved
This incident has been resolved.
Posted May 22, 2020 - 16:49 EDT
Investigating
DoIT is currently investigating reports of intermittent issues with logging into Blackboard.
Posted May 22, 2020 - 13:30 EDT
This incident affected: Student and Faculty Services (Blackboard).