DUO
Incident Report for DoIT
Resolved
This incident has been resolved.
Posted Aug 09, 2022 - 06:19 EDT
Investigating
We are currently monitoring an issue causing an outage with our Self-Service billing functionality.
Posted Aug 08, 2022 - 11:01 EDT
This incident affected: Accounts and Passwords (DUO Security Two-Factor Authentication).