Google Calendar

Incident Report for DoIT

Resolved

This incident has been resolved.
Posted Sep 21, 2023 - 12:59 EDT

Investigating

Re-posted from the 'Google Apps Dashboard',

"We're investigating reports of an issue with Google Calendar. We will provide more information shortly. The affected users are able to access Google Calendar, but are seeing error messages, high latency, and/or other unexpected behavior.
Customer symptoms: customers may see errors when clicking on events.

Workaround: refreshing the browser should work."
Posted Sep 21, 2023 - 10:37 EDT
This incident affected: G Suite (Google Apps) (Google Apps Calendar).