Google

Incident Report for DoIT

Resolved

This incident has been resolved.
Posted Jun 13, 2025 - 14:25 EDT

Investigating

We're investigating reports of an issue with Gmail, Google Calendar, Google Docs, and Google Drive. According to Google website, users had problems accessing site during the following times: (All Times US/Pacific)

Incident Start: 12 June, 2025 10:49

All regions except us-central1 mitigated: 12 June, 2025 12:48

Incident End: 12 June, 2025 13:49

Duration: 3 hours

Per Website, services are OK now.
Posted Jun 13, 2025 - 14:24 EDT
This incident affected: G Suite (Google Apps) (Google Apps Gmail, Google Apps Drive, Google Apps Calendar, Google Apps Docs).