IT Service Portal technical difficulties
Incident Report for DoIT
Resolved
This incident has been resolved.
Posted Apr 14, 2020 - 14:31 EDT
Investigating
Users reporting issues with IT Customer support ticketing system, vendor has been contacted.
Posted Apr 14, 2020 - 11:14 EDT
This incident affected: IT Service Portal (service.stonybrook.edu).