TeamDynamix - performance degradation.

Incident Report for DoIT

Resolved

TeamDynamix has marked this issue as resolved
Posted Nov 06, 2025 - 16:20 EST

Update

We are continuing to investigate this issue.
Posted Nov 06, 2025 - 16:19 EST

Investigating

Team Dynamix is currently investigating reports of performance degradation.
Posted Nov 06, 2025 - 13:49 EST
This incident affected: TeamDynamix IT Service Management Platform.