Turnitin users experiencing slowness

Incident Report for DoIT

Resolved

This incident has been resolved.
Posted May 21, 2025 - 09:20 EDT

Identified

Received from Turnitin this morning:

Simcheck, Similarity, Originality and iThenticate V2 is currently experiencing an unexpected service incident.

During this time, you may find that you encounter slowness or error messages accessing these products.

The Turnitin status page can be accessed at: https://turnitin.statuspage.io/incidents/d3bs2fwtbr91
Posted May 21, 2025 - 09:12 EDT
This incident affected: Student and Faculty Services (Turnitin).