Google AppSheets

Incident Report for DoIT

Resolved

This incident has been resolved.
Posted Apr 28, 2026 - 13:11 EDT

Investigating

Investigating issues with slow loading of AppSheets
Posted Apr 28, 2026 - 11:40 EDT
This incident affected: G Suite (Google Apps) (Google Apps Sheets).