IT Website Current Down

Incident Report for DoIT

Resolved

This incident has been resolved.
Posted Sep 15, 2023 - 06:32 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 14, 2023 - 14:48 EDT

Investigating

We are currently investigating the issue. Some users will receive the following error message when visiting the IT Website:
"Page Could Not Be Loaded".
Posted Sep 14, 2023 - 13:21 EDT
This incident affected: TeamDynamix IT Service Management Platform.