ECHO360

Incident Report for DoIT

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 16:03 EDT

Investigating

Echo360 has identified that the ongoing AWS us-east-1 region outage is intermittently impacting video processing causing some users in the U.S. East region to experience delays.
We are actively monitoring AWS recovery efforts and exploring internal mitigations where possible. Echo360 will continue to provide updates here as more information becomes available or as services recover.
Posted Oct 20, 2025 - 11:59 EDT
This incident affected: Student and Faculty Services (Echo360).