DUO 6

Incident Report for DoIT

Resolved

This incident has been resolved.
Posted Apr 28, 2026 - 11:38 EDT

Investigating

We are investigating elevated authentication latency affecting customers . Authentication requests are continuing to succeed at this time, but customers may experience slower-than-normal response times and degraded performance during login attempts. Our team is actively working to identify the cause and restore normal performance as quickly as possible.
Posted Apr 28, 2026 - 10:39 EDT
This incident affected: Accounts and Passwords (Duo Security Two-Factor Authentication).