Google Chat Issues reported

Incident Report for DoIT

Resolved

Google has posted on their site that the issues reported earlier have now been resolved.
Posted Jul 18, 2025 - 12:16 EDT

Investigating

Google has identified various degraded performance issues with Google Chat, Gmail and Meet and are working on a resolution.
Posted Jul 18, 2025 - 11:59 EDT
This incident affected: G Suite (Google Apps) (Google Apps Gmail).