Per TeamDynamix: We monitored for a time after implementing mitigations, and were able to confirm that stability remains consistent and the issue is resolved. Thank you again for reporting this to us and for your patience as it was resolved quickly.
Posted Apr 28, 2025 - 13:08 EDT
Update
Per TeamDynamix: We are investigating the source of a performance degradation that began a short time ago. As of now it seems to have been a brief spike that has subsided. We'll continue to monitor and determine the root cause. Please also refer to our status page for additional details as updates will be posted there first and then relayed through ticket reports of the issue secondly. ( status.teamdynamix.com )
Posted Apr 28, 2025 - 11:23 EDT
Monitoring
Receiving reports from the community that all seems ok now. I have not heard from TDx as of yet.
Posted Apr 28, 2025 - 11:21 EDT
Investigating
We have received several complaints about TeamDynamix being extremely slow and/or not loading. We have reported this to TeamDynamix. Please check back here for updates
Posted Apr 28, 2025 - 11:10 EDT
This incident affected: TeamDynamix IT Service Management Platform.