Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 15, 2026 - 06:00 EDT
Scheduled
We will be performing a scheduled deployment of EchoVideo as part of our ongoing commitment to delivering a reliable, high-performance platform for all users.
Deployment Schedule: April 16, 6:00 AM Eastern U.S. Duration: 60 minutes
Expected Impact: No disruption to end users is anticipated, and no downtime is expected. This release includes enhancements and updates designed to further improve system performance, stability, and overall reliability.
These proactive deployments reflect our continued investment in delivering a dependable, enterprise-grade experience you can trust.
We appreciate your understanding and continued partnership as we enhance the platform.
Posted Apr 10, 2026 - 08:34 EDT
This scheduled maintenance affected: Student and Faculty Services (Echo360).