Potential issue using Google Drive.
Incident Report for DoIT
Resolved
This incident has been resolved.
Posted May 30, 2024 - 13:35 EDT
Investigating
Copied from the Google Apps Dashboard, no indication thus far that SB users are affected.

"We're investigating reports of an issue with Google Drive. We will provide more information shortly.
Customer might see 5XX errors while using Google Drive."
Posted May 30, 2024 - 12:10 EDT
This incident affected: G Suite (Google Apps) (Google Apps Drive).