Blackboard Outage
Incident Report for DoIT
Resolved
This incident has been resolved.
Posted May 14, 2020 - 14:50 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 06, 2020 - 19:56 EDT
Investigating
DoIT is currently investigating a Blackboard outage.
Posted May 06, 2020 - 19:43 EDT
This incident affected: Student and Faculty Services (Blackboard).