Google Groups Reporting Issues
Incident Report for DoIT
Resolved
Issue with Google Groups has been resolved
Posted Nov 06, 2019 - 11:54 EST
Investigating
Per Google Apps Status; "
Status: Service disruption
We're investigating reports of an issue with Google Groups. We will provide more information shortly.
November 6, 2019 10:58:00 AM EST
Posted Nov 06, 2019 - 11:24 EST
This incident affected: G Suite (Google Apps) (Google Apps Groups).