IT Service Portal: Cherwell

Incident Report for DoIT

Resolved

Cherwell resolved the issue.
Posted Feb 06, 2020 - 13:51 EST

Investigating

We are currently investigation issues with Cherwell.
Posted Feb 06, 2020 - 12:50 EST
This incident affected: TeamDynamix IT Service Management Platform.