IT Ticketing Experiencing Degraded Performance

Incident Report for DoIT

Resolved

This incident has been resolved.
Posted May 05, 2020 - 12:10 EDT

Investigating

Cherwell (vendor) notified and investigating.
Posted May 05, 2020 - 10:33 EDT
This incident affected: TeamDynamix IT Service Management Platform.