Degreeworks - degree audit update delays
Incident Report for DoIT
Resolved
This incident has been resolved.
Posted Mar 04, 2024 - 16:13 EST
Monitoring
Due to the volume of changes during this peak period, we are currently experiencing delays for Degree Works degree audit updates. We anticipate updates will continue throughout the add/drop week
Posted Jan 23, 2024 - 16:10 EST
This incident affected: Business Systems (Degree Works).