WolfMart

Incident Report for DoIT

Resolved

This incident has been resolved.
Posted Sep 25, 2026 - 13:46 EDT

Investigating

"Digital Capture is experiencing an issue Importing Emailed Invoices
Investigation and resolution is in progress"
Posted Sep 25, 2026 - 08:14 EDT
This incident affected: Business Systems (WolfMart).