SSO Partial Outage

Incident Report for DoIT

Resolved

This incident has been resolved.
Posted Apr 17, 2025 - 16:32 EDT

Investigating

We are currently investigating an issue with SSO on the Chrome Browser.
If you're experiencing the issue, please use an alternate browser like Microsoft Edge or Safari for the time being.
Posted Apr 17, 2025 - 15:44 EDT
This incident affected: Accounts and Passwords (NetID / Single Sign On (SSO)).