DUO 52

Incident Report for DoIT

Resolved

This incident has been resolved.
Posted May 13, 2026 - 14:07 EDT

Identified

We have identified the cause of the issue causing authentication failures on DUO57 with the Duo Core Authentication Service and are actively working to restore service.
Posted May 13, 2026 - 11:36 EDT
This incident affected: Accounts and Passwords (Duo Security Two-Factor Authentication).