IT Service Portal

Incident Report for DoIT

Resolved

You can now log into portal from home page.
Posted May 20, 2020 - 18:17 EDT

Investigating

Unable to access IT Service Portal. Administrators have been notified.
Posted May 20, 2020 - 16:22 EDT
This incident affected: TeamDynamix IT Service Management Platform.