Issue with FIXIT - Investigating

Incident Report for DoIT

Investigating

The FIXIT application is currently unavailable.
We are working to resolve the issue.

We understand this outage is disruptive and we apologize for any inconvenience it may cause.
We will continue to provide updates on https://itstatus.stonybrook.edu/
Posted Sep 11, 2026 - 16:57 EDT
This incident affects: Student and Faculty Services (FIXIT).