Blackboard Loading Issues / Unavailable
Incident Report for DoIT
Resolved
This incident was related to network traffic issues early in the morning and has since been resolved.
Posted Nov 13, 2020 - 11:59 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 13, 2020 - 09:02 EST
Investigating
DoIT is currently investigating reports of slow loading times or failed webpage loads for Blackboard.
Posted Nov 13, 2020 - 08:50 EST
This incident affected: Student and Faculty Services (Blackboard).