VPN issue
Incident Report for DoIT
Resolved
This incident has been resolved.
Posted Jul 30, 2020 - 14:49 EDT
Investigating
We are currently investigating reports of VPN connection issues.
Posted Jul 30, 2020 - 14:02 EDT
This incident affected: Network, Phones and TV (Virtual Private Network (VPN)).