AccessVIZ unavailable.
Incident Report for DoIT
Resolved
This incident has been resolved.
Posted Jun 09, 2021 - 06:54 EDT
Investigating
Connection to service is unavailable. System Administrators working on a resolution.
Posted Jun 09, 2021 - 06:06 EDT
This incident affected: Business Systems (accessVIS).