Cherwell Error message.
Incident Report for DoIT
Resolved
This incident has been resolved.
Posted Nov 10, 2020 - 17:49 EST
Investigating
Getting error message while trying to login to IT Service Portal. System administrators have been informed.
Posted Nov 10, 2020 - 17:33 EST
This incident affected: IT Service Portal (service.stonybrook.edu).