DUO

Incident Report for DoIT

Resolved

This incident has been resolved.
Posted Jun 06, 2025 - 11:41 EDT

Investigating

We are currently investigating an issue causing login failures and "Invalid Credentials" messages when attempting to access the Duo Admin Panel.
Posted Jun 06, 2025 - 09:30 EDT
This incident affected: Accounts and Passwords (Duo Security Two-Factor Authentication).