Google Workspace Status Alert
Incident Report for DoIT
Resolved
This incident has been resolved.
Posted Aug 12, 2024 - 11:50 EDT
Investigating
We are currently investigating the issue.
Posted Aug 12, 2024 - 11:34 EDT
This incident affected: G Suite (Google Apps) (Google Apps Gmail, Google Apps Drive, Google Apps Calendar, Google Apps Docs).