TeamDynamix latency issues

Incident Report for DoIT

Resolved

This incident has been resolved.
Posted Sep 09, 2026 - 13:15 EDT

Monitoring

We received reports of issues with TeamDynamix this morning, Here is the latest information from their Status Page (https://status.teamdynamix.com/):

Monitoring - Performance appears to have fully returned to normal, however we will continue monitoring to ensure it remains stable.

The root cause was a configuration change that had unintended side effects, which was quickly reversed.
Sep 09, 2026 - 11:31 EDT

Investigating - We are actively investigating reports of performance degradation across Work Management the iPaaS platforms.
Sep 09, 2026 - 11:24 EDT
Posted Sep 09, 2026 - 12:24 EDT
This incident affected: TeamDynamix IT Service Management Platform.