Google Drive.
Incident Report for DoIT
Resolved
This incident has been resolved.
Posted Sep 15, 2020 - 12:37 EDT
Investigating
Re-posted from the Google Apps Status Page, there is no indication so far that SBU clients are affected,

"We're investigating reports of an issue with Google Drive. We will provide more information shortly. The affected users are able to access Google Drive, but are seeing error messages, high latency, and/or other unexpected behavior."
Posted Sep 15, 2020 - 11:05 EDT
This incident affected: G Suite (Google Apps) (Google Apps Drive).