Academic Technologies Live Chat service is currently unavailable
Incident Report for DoIT
Resolved
Service has been restored.
Posted Sep 10, 2020 - 11:40 EDT
Investigating
it.stonybrook.edu/chat is not working. We have notified the company and are waiting for them to resolve the issue. Should you require assistance, please submit a ticket online at: service.stonybrook.edu OR call 631-632-9800.
Posted Sep 10, 2020 - 08:19 EDT
This incident affected: Student and Faculty Services (Live Chat).