IT Service Portal Unavailable

Incident Report for DoIT

Resolved

This incident has been resolved.
Posted Mar 23, 2020 - 16:54 EDT

Identified

The vendor has identified the issue and is working on a resolution.
Posted Mar 23, 2020 - 14:33 EDT

Update

We are continuing to investigate this issue.
Posted Mar 23, 2020 - 14:25 EDT

Investigating

Unable to log in to create tickets, admins have been notified.
Posted Mar 23, 2020 - 14:25 EDT
This incident affected: TeamDynamix IT Service Management Platform.