FIXIT unavailable.
Incident Report for DoIT
Resolved
This incident has been resolved.
Posted Nov 21, 2022 - 10:18 EST
Update
We are continuing to investigate this issue.
Posted Nov 21, 2022 - 10:17 EST
Investigating
Access to the FIXIT service is unavailable. System Administrators working on a resolution.
Posted Nov 21, 2022 - 06:51 EST
This incident affected: Student and Faculty Services (FIXIT).